V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
fvladlpa
V2EX  ›  问与答

ocserv 0.9 直接使用 freeradius 认证问题

  •  
  •   fvladlpa · 2015-02-02 09:04:45 +08:00 · 7990 次点击
    这是一个创建于 2502 天前的主题,其中的信息可能已经有所发展或是发生改变。
    请问大家为什么我直接在ocserv config文件里面开启
    auth = "radius[/etc/radiusclient/radiusclient.conf,groupconfig]"
    然后再重启ocserv服务的时候直接报错
    Starting OpenConnect VPN Server Daemon: Radius support is disabled
    好像是说Radius不支持,但是在config文件里面有这个选项。难道radiusclient需要添加一些特殊的attribute吗?
    我的pptp是通过freeradius认证的没问题,另外我没有用PAM方式。
    第 1 条附言  ·  2015-02-15 12:40:47 +08:00
    解决问题了,谢谢大家
    是radiusclient的问题,必须要使用版本至少是1.1.7的客户端。我之前安装的是1.1.6,因此出错。重新编译安装1.1.7即可
    13 条回复    2015-07-25 18:02:27 +08:00
    chon
        1
    chon  
       2015-02-02 09:15:27 +08:00
    还是用PAM-Radius吧
    fvladlpa
        2
    fvladlpa  
    OP
       2015-02-02 09:41:28 +08:00
    @chon 我觉得应该是哪里设置的不对,在ocserv最新的changelog里面
    dded native support for radius. That adds the new auth configuration option "radius", which has as parameters the freeradius-client configuration file and optionally the groupconfig option which instructs to read configuration from radius; the stats-report-time option enables interim-updates. That adds the dependency to freeradius-client (see doc/README.radius).
    是原生支持的
    ooxxcc
        3
    ooxxcc  
       2015-02-02 09:41:37 +08:00
    编译的时候少了什么选项,或者少装了什么依赖,导致radius功能没编译上
    yywudi
        4
    yywudi  
       2015-02-02 09:42:01 +08:00 via Android
    pam_radius能用,暂时不折腾
    fvladlpa
        5
    fvladlpa  
    OP
       2015-02-02 09:52:54 +08:00
    @ooxxcc 在change log里面看到 depend on freeradius-client 1.1.7,我的ubuntu服务器装的是radiusclient1,请问各位这两个client是同一个吗?
    ooxxcc
        6
    ooxxcc  
       2015-02-02 09:54:57 +08:00
    @fvladlpa 自己研究,和发行版有关

    你应该试试-dev结尾的

    然后试试 --with_radius 选项
    knightluffy
        7
    knightluffy  
       2015-02-02 10:25:35 +08:00
    free-radius 1.X都停止维护了,竟然还有人在用。。。
    fvladlpa
        8
    fvladlpa  
    OP
       2015-02-02 10:30:38 +08:00
    @knightluffy 是 freeradius client啊
    xierch
        9
    xierch  
       2015-02-02 12:32:35 +08:00
    编译的时候少了依赖吧.. 你看下 ./configure 的输出里会有写的..
    pam_radius 主要是不带(?) accounting..
    ziggear
        10
    ziggear  
       2015-02-09 17:38:41 +08:00
    ./configure --with-radius
    liang1985
        11
    liang1985  
       2015-02-15 11:32:43 +08:00   ❤️ 1
    0.9必须用git里面的那个radiusclient才可以,./configure的时候你看看Radius auth backend是不是显示no
    chenhuaecho
        12
    chenhuaecho  
       2015-07-03 14:35:07 +08:00
    我也遇到了radius disabled 的问题 我已经把freeradius-client 升级编译了1.1.7 但还是报这次错误,求助!
    xav1er
        13
    xav1er  
       2015-07-25 18:02:27 +08:00
    @fvladlpa 你好,请问有相关 ocserv freeradius 的教程吗?
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3791 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 20ms · UTC 08:22 · PVG 16:22 · LAX 00:22 · JFK 03:22
    ♥ Do have faith in what you're doing.