首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
shiznet
V2EX  ›  MacBook Air

MacBookAir 特定无线网络下不稳定

  •  
  •   shiznet · 2015-06-13 11:56:03 +08:00 · 5107 次点击
    这是一个创建于 1682 天前的主题,其中的信息可能已经有所发展或是发生改变。
    • 在家使用的无线路由,其他设备没有问题,只有mba经常会连接在但是无法上网,ping外网不通,但是能连无线的管理平台。
    • MBA在家以外的无线环境下没有问题。

    不知道是路由器的问题还是mba的问题,有遇到相同问题的同学么?或者有谁能麻烦提供下一些排查的思路么?

    第 1 条附言  ·  2015-06-13 12:47:41 +08:00
    问题描述有误
    mba链接无线之后是能够正常工作的,但是在一段时间之后(十几分钟到几十分钟不等)就不能正常工作了,问题与原描述相同。
    第 2 条附言  ·  2015-06-15 10:02:01 +08:00
    附加上我的路由器的信息
    tplink WR710N
    Router 模式
    11bg mixed
    信道模式:自动(记录时刻使用的是6)
    第 3 条附言  ·  2015-06-17 23:02:50 +08:00
    http://mrnoidea.com/626
    有同学使用连接提供的方法恢复了,感觉像是什么黑魔法一样的解决方案。
    30 回复  |  直到 2015-10-02 15:34:29 +08:00
    yangxiongguo
        1
    yangxiongguo   2015-06-13 12:02:08 +08:00
    换一下路由器的信道?
    edwardaa
        2
    edwardaa   2015-06-13 12:03:17 +08:00
    根据你的陈述:
    是不是Mac的mac地址被你的路由器屏蔽了。。。。。
    shiznet
        3
    shiznet   2015-06-13 12:07:52 +08:00
    @edwardaa

    当没办法访问外部网络的时候,我就重新连接,然后就可以了,但是不知道什么时候又会抽风没办法连接。
    mac地址被屏蔽的话应该一直都没办法访问吧。

    @yangxiongguo
    信道现在是用的自动,加上mac一共有个4个设备连接。
    edwardaa
        4
    edwardaa   2015-06-13 12:16:37 +08:00   ♥ 1
    @shiznet 你的陈述完全没有提到过你的Mac能上网,只能连接ap,完全符合mac地址被屏蔽的特征。
    mdrof
        5
    mdrof   2015-06-13 12:22:32 +08:00
    路由初始化
    shiznet
        6
    shiznet   2015-06-13 12:45:40 +08:00 via iPhone
    @edwardaa 额额 描述有问题 我改下 刚链接能上外网一切正常 但是过后就不行了
    yangxiongguo
        7
    yangxiongguo   2015-06-13 12:54:31 +08:00
    @shiznet 信道改成手动的试试。你说有四个设备连接跟信道没关系呀,又不是 IP 地址。
    874808862
        8
    874808862   2015-06-13 13:08:15 +08:00
    肯定是无线本身的问题
    Axighi
        9
    Axighi   2015-06-13 13:13:01 +08:00
    没想到有人遇到跟我一样的问题!!!!!现在的解决方案是登陆路由器,断开连接,重新连接即可.但这个办法不总是管用,不好使就只能等段时间,然后就可以上网了.
    shiznet
        10
    shiznet   2015-06-13 13:30:32 +08:00 via iPhone
    @Axighi 握手!我这面就是断开连接重连 但是一会又跪了
    lksltjw
        11
    lksltjw   2015-06-13 13:34:47 +08:00
    是不是装了shadowsocks之类可以更改系统代理的软件?
    我的mba装了shadowsocks,开机后(或睡眠重新激活后)会有一段时间上不了网,nslookup显示不是dns的问题,ping ip能ping通但是ping地址确ping不通,然后chrome用switch omega调到直接连接却能上网。。。
    也不知道是什么原因
    cyancat
        12
    cyancat   2015-06-13 14:09:40 +08:00
    MBP13,和楼主一样的问题。

    ……
    然而并没有什么卵用,我也没解决……

    只知道断的时候重新连一下或者重新分配一下 IP 就会恢复。
    虽然我一直以为是电力猫的问题 :doge:
    shiznet
        13
    shiznet   2015-06-13 15:08:48 +08:00 via iPhone
    @lksltjw 之前是有装过ss5的一个软件 我找时间看看是不是这个原因
    shiznet
        14
    shiznet   2015-06-13 15:09:31 +08:00 via iPhone
    @cyancat 我的只是在家里的有问题 在其他的网络暂时还没有过...
    choury
        15
    choury   2015-06-13 15:21:59 +08:00
    @shiznet 添加个位置,给个名字,比如“家”,试试看
    ihonker
        16
    ihonker   2015-06-13 18:37:40 +08:00
    我觉得跟系统版本您有问题,我和我另外三个同事的mbp,都是10.10.3的系统,前段时间,都出现过,在公司里能连上路由但是不能上网,拿回家上网正常的现象。
    后来,公司换了路由,我们都能正常上网了。
    shiznet
        17
    shiznet   2015-06-13 21:20:37 +08:00 via iPhone
    @ihonker 问题好像还不大一样 看我后来的append 刚开始链接是可用的 一段时间之后不可用 现在在外面 系统问题到时候升下capitan看看能不能解决 多谢 anyway
    2exco
        18
    2exco   2015-06-14 05:16:01 +08:00
    相同的问题,mbp13, OSX 10.10.3.
    在家经常断(802.11n)
    外面不常断(802.11ac)
    怀疑:
    1. 系统问题
    2. 路由器问题
    Gandum
        19
    Gandum   2015-06-14 05:53:14 +08:00 via iPhone
    正确思路是关掉AWDL/Airdrop
    执行sudo ifconfig awdl0 down,立马一切毛病都好了,鸡肋的Airdrop也关了
    hackevin
        20
    hackevin   2015-06-14 07:57:53 +08:00
    我也碰到过,感觉跟路由关系很大。Air和MBP同样。
    不光一会儿断,有时根本就连不上WIFI。
    shiznet
        21
    shiznet   2015-06-15 09:57:07 +08:00
    @2exco 家里现在用的是11bg mixed
    恩 现在看应当是系统+路由的问题 这个排查起来就比较郁闷了
    shiznet
        22
    shiznet   2015-06-15 10:02:58 +08:00
    @hackevin
    @2exco
    @ihonker
    @cyancat
    @Axighi
    能帮忙附一下路由器的相关信息么 看看有没有什么相似的地方 以方便排查下问题
    2exco
        23
    2exco   2015-06-15 14:43:03 +08:00
    多合一路由(modem,路由器,电话,电视),802.11n。
    mbpr显示Tx速率:217Mbps,安全性:WPA2(个人级)。
    估计10.10.3对ac路由支持好点,可能内置ac网卡的原因。
    网卡是Broadcom BCM43xx 1.0 (7.15.166.24.3)。
    路由可能不是Broadcom的芯片,所以支持不好。
    cyancat
        24
    cyancat   2015-06-15 15:44:15 +08:00
    @shiznet 其实我试了 @Gandum 的方法,目前为止似乎是有效的……
    不过这个问题的出现情况比较随机,现在也不太好说。

    我的路由是 TL-WR840N,用了4年多了老型号了。
    http://item.jd.com/1581351090.html

    换 MBP 之前,甚至之前的 MBA 跑 Mavericks 的时候也是完全没碰到过这问题嗯。
    shiznet
        25
    shiznet   2015-06-15 17:31:15 +08:00 via iPhone
    @cyancat 已经关了 你重启mac了么?我还是不行
    换信道也不行 试过了 13个信道都试了
    @yangxiongguo
    2exco
        26
    2exco   2015-06-17 05:25:06 +08:00
    @shiznet 我这几天正常了些。
    方法类似 @choury所说,
    详细步骤 http://mrnoidea.com/626 , 设置完必须重启电脑。
    现在用完电脑就关机而不是直接关闭盖子,没再出现断线现象。
    shiznet
        27
    shiznet   2015-06-17 23:02:05 +08:00
    @2exco 我一直都是自己添加的位置 没用的自动。。。信道我这个也调了,真是日了狗了
    2exco
        28
    2exco   2015-06-18 08:08:17 +08:00
    @shiznet
    换个路由看看效果。
    shiznet
        29
    shiznet   2015-06-18 09:46:04 +08:00
    @2exco
    恩 打算节后换个路由器了
    thank243
        30
    thank243   2015-10-02 15:34:29 +08:00
    我靠,真是黑科技啊,通过 lz 贴条的方法解决了。。。
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1746 人在线   最高记录 5168   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 28ms · UTC 16:38 · PVG 00:38 · LAX 08:38 · JFK 11:38
    ♥ Do have faith in what you're doing.