V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
abug
V2EX  ›  iOS

App 开发者需要更新此 App 以在此 iOS 版本上正常工作

  •  
  •   abug · 43 天前 · 946 次点击
    这是一个创建于 43 天前的主题,其中的信息可能已经有所发展或是发生改变。

    今天打测试包出现这个,百度结果都说要升级系统,可是我的是老电脑,升不了级了啊,有没有其它办法解决啊

    14 条回复    2021-10-21 12:58:15 +08:00
    salor
        1
    salor  
       43 天前 via iPhone
    给你一个买 m1 max 改变世界的机会。
    如果买了也没改变世界,那就是没买 32 核 64G 。
    laoyur
        2
    laoyur  
       43 天前
    Xcode 升级到 12.5.1,但你是老电脑,估计不行了
    abug
        3
    abug  
    OP
       43 天前
    @laoyur 只有换电脑了吗?搞得这么绝
    ETiV
        4
    ETiV  
       43 天前 via iPhone
    用 GitHub action 出包
    或者 AWS 买 macOS 机型
    laoyur
        5
    laoyur  
       43 天前
    @abug 就是这么绝哦
    不过你可以破釜沉舟自己试一下,把导出后的 ipa 里 Info.plist 里的 xcode 啊,编译器啥的相关字段改成 12.5.1+上的,再重签名,也许能 work 也说不准哦
    minamike
        6
    minamike  
       43 天前
    就我想知道是啥时候的机器吗
    icyalala
        7
    icyalala  
       43 天前
    Big Sur 能兼容到 2013 款的 Mac 吧。。
    楼主电脑难道是十年前的?
    abug
        8
    abug  
    OP
       43 天前
    @icyalala 12 年的,看来刚不动了
    thisfin
        9
    thisfin  
       43 天前
    你平时 debug 不会觉得慢么
    cairnechen
        10
    cairnechen  
       43 天前
    @abug 12 年的还能用来开发也太强了吧
    icyalala
        11
    icyalala  
       43 天前
    @abug 这确确实实太老了。。实在没办法弄个二手的老 mac mini 专门打包也凑合
    wunonglin
        12
    wunonglin  
       43 天前
    9 年了大哥。确实坚挺。。。不过是时候到头了
    wunonglin
        13
    wunonglin  
       43 天前
    有个想法。。。Mac 上不是可以用 Mac 镜像的虚拟机么?搞一个高版本的虚拟机行不?
    minamike
        14
    minamike  
       43 天前
    https://github.com/barrykn/big-sur-micropatcher 用这个补丁说不定能勉强升级 Big Sur
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1615 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 29ms · UTC 00:54 · PVG 08:54 · LAX 16:54 · JFK 19:54
    ♥ Do have faith in what you're doing.