V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
FaiChou
V2EX  ›  iOS

使用 M1 做 iOS 开发遇到 pod install ruby 问题你们都怎么解决?

  •  1
     
  •   FaiChou · 148 天前 · 1242 次点击
    这是一个创建于 148 天前的主题,其中的信息可能已经有所发展或是发生改变。

    一开始遇到这个问题:

    ruby 问题

    搜索一番发现是 M1 的原因, 并找了 CocoaPods/issues/9890 这个解决方法:

    $ sudo arch -x86_64 gem install ffi
    $ arch -x86_64 pod install
    

    然后编译成功了.

    后来又搜了一下, 基本全部是用这个方法处理的:

    rossetta2

    但考虑到使用 rosetta2 进行转译, 这样效率大打折扣啊? 而且编译后结果都是 x86 的执行格式, 而且是传染性的, 以后复用这个库, 都得切指令.

    所以, 你们怎么处理的?

    7 条回复    2022-02-11 17:37:21 +08:00
    KyleYe
        1
    KyleYe  
       147 天前 via iPhone
    不要使用系统自带的 ruby ,貌似用 rbenv 之类的装个重新 2.6.8 就可以了
    jk234ert
        2
    jk234ert  
       147 天前
    ```
    sudo gem uninstall cocoapods

    brew install cocoapods
    ```
    https://github.com/CocoaPods/CocoaPods/issues/9907
    Sixi
        3
    Sixi  
       147 天前
    如 @jk234ert 所说,使用 Homebrew 安装 cocoapods
    xoioao
        4
    xoioao  
       147 天前
    gem uninstall ffi
    gem install ffi -- --enable-libffi-alloc

    https://github.com/ffi/ffi/issues/800#issuecomment-1008308614
    Building
        5
    Building  
       147 天前 via iPhone   ❤️ 1
    改用 SwiftPackage 了
    FaiChou
        6
    FaiChou  
    OP
       147 天前
    @Building RN 还是用的 pod..


    @xoioao 谢谢 我试试.
    wancj17
        7
    wancj17  
       145 天前
    直接用 Homebrew 装 ruby 3.0 解决
    我也是 m1 的
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3996 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 29ms · UTC 03:53 · PVG 11:53 · LAX 20:53 · JFK 23:53
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.