V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
测试工具
SmokePing
IPv6 访问测试
mlboy
V2EX  ›  宽带症候群

求助,网络拓扑问题

  •  
  •   mlboy · 146 天前 · 1103 次点击
    这是一个创建于 146 天前的主题,其中的信息可能已经有所发展或是发生改变。

    背景

    买了个电视盒子,想看视频.

    拓扑描述

    光猫(联通)--(brige)--路由器(xiaomi-AX6000)

    其他设备君连接在 AX6000 路由器下 (GW:192.168.31.1)

    包括: 电视,电视盒子,手机,电脑,群辉. 等智能设备

    已知这些设备均可联网.

    折腾,在群辉中用 docker 装 openwrt 当旁路由用

    群辉通过 docker 方式装了原版 openwrt (image: openwrtorg/rootfs:latest)

    群辉上设置了 网卡混杂

    sudo ip link set eth0 promisc on 
    

    openwrt 容器通过 macvlan 桥接群辉 host (ADDR:192.168.31.2)

    docker network create -d macvlan --subnet=192.168.31.0/24 --gateway=192.168.31.1 -o parent=eth0 macnet
    

    openwrt 容器中配置了 (默认网关 192.168.31.1)

    route add default gw 192.168.31.1
    

    设备 ip 情况:

    ax6000: 192.168.31.1
    openwrt: 192.168.31.2  gw:192.168.31.1
    群辉:  192.168.31.254   gw:192.168.31.1
    电脑 1: 192.168.31.100   gw:192.168.31.1
    手机 1: 192.168.31.102   gw:192.168.31.2 
    

    现象

    openwrt 容器中: 可以正常访问外网

    群辉: 可以正常访问外网

    电脑 1: 可以正常访问外网\群辉\openwrt

    手机 1: 只可以访问内网即可以访问 192.168.31.1 ,也可访问 192.168.31.2 但是不能访问外网

    期望

    期望 手机 1 可以访问外网.

    猜测

    应该是缺少一个路由,或者 nat 设置,将手机 1 上的流量转到外网.

    小白不懂网络,求赐教,问题出在哪里了?

    类似这种配置

    iptables -t nat -I POSTROUTING -j MASQUERADE 
    
    6 条回复    2022-05-10 10:23:44 +08:00
    lcy630409
        1
    lcy630409  
       146 天前
    上不了网 找网关的麻烦啊
    你把手机网关设为 31.1 试试 ,应该可以
    大概是你的 openwrt 没有设置好 wan ,一般的话 建议虚拟两个网卡,在同一个网络里,一个作为 wan 一个作为 lan ,即可,最简单的做法
    mlboy
        2
    mlboy  
    OP
       146 天前
    @lcy630409 设置 31.1 肯定是行的.现在就是想通过 32.2 旁路由的方式上网.毕竟旁路由上是装了直通 V2EX 的科学工具的.
    目前 openwrt 上的配置是一个 lan.
    如下:
    ```
    [email protected]:~# cat /etc/config/network

    config interface 'loopback'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'
    option device 'lo'

    config interface 'lan'
    option proto 'static'
    option ipaddr '192.168.31.2'
    option netmask '255.255.255.0'
    option gateway '192.168.31.1'
    list dns '192.168.31.1'
    option device 'eth1'

    config route
    option interface 'lan'
    option target '0.0.0.0/0'
    option gateway '192.168.31.1'
    ```
    lcy630409
        3
    lcy630409  
       146 天前
    @mlboy
    这问题不就来了么....
    把 lan 里面的桥接不勾选
    新建一个 wan ,dhcp 客户端,网口同样选择那个网卡,应该就可以了
    lcy630409
        4
    lcy630409  
       146 天前
    他们那种写转发规则的我不会,你想搞那样的 可以百度一下,关键词应该是 openwrt 单臂路由
    xdzhang
        5
    xdzhang  
       146 天前
    iptables -t nat -I POSTROUTING -o eth1 -j MASQUERADE
    AlexShui
        6
    AlexShui  
       146 天前 via Android
    我现在这个和你想的差不多差不多?但是我的方案是在群晖下的虚拟机中装的 openwrt 。虚拟机给软路由分配空间很方便,也支持 ISO 和 img 文件导入,还可以保存快照,方便回复,当然开机自启也没有问题

    对了我用的 istoreOS ,基于 openwrt ,这个固件唯一便捷的一点就是设置旁路由的网络模式非常简单,点选一下就可以了。

    这个单臂旁路由的组网方式是,主路由开启 DHCP ,网关和 DNS 都是旁路由的地址。

    目前作为旁路由开了 smartDNS , adguard, passwall 三者配合,还算不错,也可以开启 ipv6 ,方便远程登陆群晖。
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1234 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 44ms · UTC 17:51 · PVG 01:51 · LAX 10:51 · JFK 13:51
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.