V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
推荐学习书目
Learn Python the Hard Way
Python Sites
PyPI - Python Package Index
http://diveintopython.org/toc/index.html
Pocoo
值得关注的项目
PyPy
Celery
Jinja2
Read the Docs
gevent
pyenv
virtualenv
Stackless Python
Beautiful Soup
结巴中文分词
Green Unicorn
Sentry
Shovel
Pyflakes
pytest
Python 编程
pep8 Checker
Styles
PEP 8
Google Python Style Guide
Code Style from The Hitchhiker's Guide
chaixiaomu
V2EX  ›  Python

Python 小白,成功安装了 pygal 和 matplotlib,缺无法导入。

  •  
  •   chaixiaomu · 2019-05-17 14:12:05 +08:00 · 2390 次点击
    这是一个创建于 985 天前的主题,其中的信息可能已经有所发展或是发生改变。

    如题所示,我是 python 小白用户,在 MacBook 通过 pip3 命令成功安装了 pygal 和 matplotlib 库,但是导入报错,不知如何解决,恳求大神援助。

    信息如下:

    Last login: Fri May 17 14:00:51 on ttys000 chaixiaomudeMacBook-Pro% pip3 install pygal Requirement already satisfied: pygal in /usr/local/lib/python3.7/site-packages (2.4.0) chaixiaomudeMacBook-Pro% python3 Python 3.7.0 (v3.7.0:1bf9cc5093, Jun 26 2018, 20:42:06) [GCC 4.2.1 (Apple Inc. build 5666) (dot 3)] on darwin Type "help", "copyright", "credits" or "license" for more information.

    import pygal Traceback (most recent call last): File "<stdin>", line 1, in <module> ModuleNotFoundError: No module named 'pygal'</module></stdin>

    25 条回复    2019-05-23 13:39:56 +08:00
    jianzhao123
        1
    jianzhao123  
       2019-05-17 14:22:57 +08:00 via iPhone
    No model named xxx 不就是没安装成功吗
    mainlong
        2
    mainlong  
       2019-05-17 14:33:17 +08:00 via Android
    请谷歌“ no module named pygal ”


    安装的不对
    wanzy
        3
    wanzy  
       2019-05-17 14:38:19 +08:00 via iPhone   ❤️ 1
    可能是你的 pip 指向的不是你正在用的 python,可以用 pip3 — version 和 which python3 来确认一下
    renyiky
        4
    renyiky  
       2019-05-17 14:50:57 +08:00 via Android
    应该是用不同方法装了好几个版本的 python。brew 或者官网安装包或者 anaconda 之类的吧。用 which python,which pip 查一查
    lostberryzz
        5
    lostberryzz  
       2019-05-17 14:54:21 +08:00
    还是用 venv 吧,方便一点
    lostberryzz
        6
    lostberryzz  
       2019-05-17 14:54:31 +08:00
    或者 conda
    RBQMT
        7
    RBQMT  
       2019-05-17 14:55:51 +08:00
    先安装虚拟环境
    chaixiaomu
        8
    chaixiaomu  
    OP
       2019-05-17 14:59:23 +08:00
    @renyiky
    MacBook-Pro% pip3 -V
    pip 19.0.2 from /usr/local/lib/python3.7/site-packages/pip (python 3.7)
    MacBook-Pro% which python3
    /Library/Frameworks/Python.framework/Versions/3.7/bin/python3

    目前看应该不是在一个目录
    chaixiaomu
        9
    chaixiaomu  
    OP
       2019-05-17 14:59:59 +08:00
    @jianzhao123 我先是
    pip3 install pygal

    然后在导入的,我看其他地方也是这个顺序
    chaixiaomu
        10
    chaixiaomu  
    OP
       2019-05-17 15:00:08 +08:00
    @mainlong 好的,谢谢提醒。
    zeroDev
        11
    zeroDev  
       2019-05-17 15:00:17 +08:00 via Android
    初学 Python,请使用现成的 IDE
    chaixiaomu
        12
    chaixiaomu  
    OP
       2019-05-17 15:00:32 +08:00
    @renyiky 嗯嗯,谢谢哈
    chaixiaomu
        13
    chaixiaomu  
    OP
       2019-05-17 15:00:51 +08:00
    @lostberryzz 我试试这个,
    chaixiaomu
        14
    chaixiaomu  
    OP
       2019-05-17 15:02:06 +08:00
    @RBQMT 我是看教程?《 python 编程从入门到实践》,Django 项目,好像是在虚拟环境里用这个的,我现在也有虚拟环境,我尝试一下,谢谢
    chaixiaomu
        15
    chaixiaomu  
    OP
       2019-05-17 15:02:42 +08:00
    @zeroDev 好的,我找一下比较好的,现在还都在用 IDLE
    RBQMT
        16
    RBQMT  
       2019-05-17 15:04:10 +08:00
    @chaixiaomu 不使用虚拟环境,以后项目多了会非常蛋疼
    zeroDev
        17
    zeroDev  
       2019-05-17 15:04:48 +08:00 via Android
    @chaixiaomu 你可以试试 pycharm
    frostming
        18
    frostming  
       2019-05-17 15:50:01 +08:00   ❤️ 1
    我写了一篇文章解答这类问题
    https://frostming.com/2019/03-13/where-do-your-packages-go


    @RBQMT 用虚拟环境是 best practice 怎么导你这蛋疼了?
    不想管虚拟环境,方法有的是

    virtualenvwrapper, pipenv, pyenv, conda
    frostming
        19
    frostming  
       2019-05-17 15:50:55 +08:00
    @RBQMT 少看一个字,然后不能删回复。。
    RBQMT
        20
    RBQMT  
       2019-05-17 15:51:51 +08:00
    @frostming。。。。。我刚想说我用的是 virtualenvwrapper
    junjieyuanxiling
        21
    junjieyuanxiling  
       2019-05-17 16:53:51 +08:00 via Android
    @chaixiaomu #15 idle 是真的垃圾,用终端都比这个强
    Yourshell
        22
    Yourshell  
       2019-05-17 18:58:42 +08:00
    先 python shell 中 import 试试
    anonymous256
        23
    anonymous256  
       2019-05-17 19:13:27 +08:00 via Android
    可能你的电脑有两个不同版本的 python。
    pip3 成功了,但是用的是 python2
    anonymous256
        24
    anonymous256  
       2019-05-17 19:17:47 +08:00 via Android
    import sys
    print(sys.version_info)

    看下你输出的 python 版本,就知道了。
    而且,你可以进入 site-packages 目录下看看你的包在不在
    chaixiaomu
        25
    chaixiaomu  
    OP
       2019-05-23 13:39:56 +08:00
    python3 -m pip install 用这个方法解决了
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3943 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 25ms · UTC 03:40 · PVG 11:40 · LAX 19:40 · JFK 22:40
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.