V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
推荐学习书目
Learn Python the Hard Way
Python Sites
PyPI - Python Package Index
http://diveintopython.org/toc/index.html
Pocoo
值得关注的项目
PyPy
Celery
Jinja2
Read the Docs
gevent
pyenv
virtualenv
Stackless Python
Beautiful Soup
结巴中文分词
Green Unicorn
Sentry
Shovel
Pyflakes
pytest
Python 编程
pep8 Checker
Styles
PEP 8
Google Python Style Guide
Code Style from The Hitchhiker's Guide
shikimoon
V2EX  ›  Python

尝试诸多方法无果。无奈求教。pip 无法安装 package

  •  
  •   shikimoon · 261 天前 · 1252 次点击
    这是一个创建于 261 天前的主题,其中的信息可能已经有所发展或是发生改变。

    用的 pycharm ,以前还是可以的。最近几天突然安装不了。提示 Could not fetch URL https://pypi.org/simple/fastapi/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443) 在尝试添加--trusted-host pypi.python.org 和-i https://mirrors.aliyun.com/pypi/simple/ 换 mobaxterm 和 powershell ,cmd 依然不行 甚至 chatgpt 说检查 openssl 。重新安装了还是不行。 我的是 win10.对面同事用的 ubuntu 就正常

    16 条回复    2023-11-02 09:32:02 +08:00
    milukun
        1
    milukun  
       261 天前
    切换豆瓣源
    knva
        2
    knva  
       261 天前
    如果是自己编译的 python 没加 ssl 模块是会这样的
    使用 http 的源应该就可以了。
    ronen
        3
    ronen  
       261 天前
    错误挺常见的,提供下你的 python 版本和 pip 版本吧。
    哦 openssl 的版本也给一下。
    shikimoon
        4
    shikimoon  
    OP
       261 天前
    @milukun 国内几个主流的源都试过了
    shikimoon
        5
    shikimoon  
    OP
       261 天前
    @knva 不是自己编译的。就一些常见的包,比如 fastapi ,uvicorn ,numpy 之类的
    jianchang512
        6
    jianchang512  
       261 天前
    本机是否开启代理,暂时关掉所有代理,系统代理也清除
    knva
        7
    knva  
       261 天前
    @shikimoon 把所有 python 都卸载了,确保只有一个 python 之后再安装
    shikimoon
        8
    shikimoon  
    OP
       261 天前
    @ronen python3.9.11,pip23.1.2,openssl3.1.3
    shikimoon
        9
    shikimoon  
    OP
       261 天前
    @jianchang512 无代理。公司网络自带 fq 。怀疑是公司网络问题。这些安装包的地址都能在网页打开的
    shikimoon
        10
    shikimoon  
    OP
       261 天前
    @knva 只装了一个 python 。
    shikimoon
        11
    shikimoon  
    OP
       261 天前
    关闭局域网代理后好了。结贴。感谢楼上回复的各位大佬
    ronen
        12
    ronen  
       261 天前
    最近墙好像确实加高了。 但是解释不了你的同事能用的问题。


    要不,你,也用 ubuntu ?
    evemoo
        13
    evemoo  
       260 天前
    cmder + Clash 没配置终端代理的时候很常见
    learningman
        14
    learningman  
       260 天前 via Android
    https://github.com/pypa/pip/issues/9190
    python 老毛病了,不过应该修了啊,你多久没更新了
    tuoov
        15
    tuoov  
       260 天前
    代理导致 TLS 握手失败,关代理
    darklinden
        16
    darklinden  
       260 天前
    pip 如果拉取包如果是 github 的需要 https 代理,socks5 不行
    如果不走 github 的包不走代理也能拉取,但是会慢
    可以先安装 pysocks ,然后 socks5 代理可行
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   实用小工具   ·   2495 人在线   最高记录 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 29ms · UTC 12:36 · PVG 20:36 · LAX 05:36 · JFK 08:36
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.