V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
iOS 开发实用技术导航
NSHipster 中文版
http://nshipster.cn/
cocos2d 开源 2D 游戏引擎
http://www.cocos2d-iphone.org/
CocoaPods
http://cocoapods.org/
Google Analytics for Mobile 统计解决方案
http://code.google.com/mobile/analytics/
WWDC
https://developer.apple.com/wwdc/
Design Guides and Resources
https://developer.apple.com/design/
Transcripts of WWDC sessions
http://asciiwwdc.com
Cocoa with Love
http://cocoawithlove.com/
Cocoa Dev Central
http://cocoadevcentral.com/
NSHipster
http://nshipster.com/
Style Guides
Google Objective-C Style Guide
NYTimes Objective-C Style Guide
Useful Tools and Services
Charles Web Debugging Proxy
Smore
66beta
V2EX  ›  iDev

XCode 里下载不到 ios 12 以下的镜像了,排查问题好不方便,到底咋想的?

  •  
  •   66beta ·
    66beta · 206 天前 · 3813 次点击
    这是一个创建于 206 天前的主题,其中的信息可能已经有所发展或是发生改变。
    APP 支持到 9.0,用户是 10.3 ;

    公司没有对应版本的测试机可以复现,打算用模拟器,下完 XCode 发现只能下载 12+的镜像;

    什么鬼?苹果处于什么目的?
    26 条回复    2021-05-08 13:44:07 +08:00
    Vegetable
        1
    Vegetable   206 天前
    哎?同问,我费劲九牛二虎之力装上的 Xcode,结果打开模拟器之后下载了 ios11 的镜像,创建模拟器却都只能选 14.4,这是为什么...
    finab
        3
    finab   206 天前
    @Vegetable
    可能是型号问题,选一个老型号试试。
    有些模拟器型号不支持低版本的系统,例如不能给 iPhone 12 装个 iOS9
    mervin3e
        4
    mervin3e   206 天前
    @mervin3e 回复错了,,,
    lagoon
        5
    lagoon   206 天前
    ios 9 是 15 年发布,ios10 是 16 年发布。

    单纯感叹兼容好早的啊,有点猛。
    fxckrx
        6
    fxckrx   206 天前
    先去 Xcode components 下载 iOS 10 的模拟器,才能新建 iOS 10 的模拟器,Xcode 12.4 还有 iOS 10.3.1 的模拟器。
    66beta
        7
    66beta   206 天前
    @fxckrx components 里只有 12+
    wipbssldo
        8
    wipbssldo   206 天前
    我的 Xcode 里面能下载到 11.0
    tsanie
        9
    tsanie   206 天前
    fxckrx
        10
    fxckrx   206 天前
    @66beta Xcode 12.5 ?
    66beta
        11
    66beta   206 天前
    @tsanie 多谢,放弃了,一个个试太浪费时间了,旧版好像跟 bigsur 还不太兼容
    66beta
        12
    66beta   206 天前
    @fxckrx 船新的,中文才装的
    66beta
        13
    66beta   206 天前
    @fxckrx Version 12.5 (12E262)
    fxckrx
        14
    fxckrx   206 天前
    @66beta 我的项目在 Xcode 12.5 下直接编译失败,滚回 12.4 了
    66beta
        15
    66beta   206 天前
    @fxckrx 所以 12.4 里确实可以下载 ios 10.3 ?
    hauibojek
        16
    hauibojek   206 天前
    公司没测试机就别兼容了吧。
    lzihua
        17
    lzihua   206 天前
    咸鱼买个对应系统版本的手机好了
    en20
        18
    en20   206 天前
    一个手机用五年的用户你还指望他给你冲钱? 直接放弃
    lostberryzz
        19
    lostberryzz   206 天前
    @en20 好思路
    tagtag
        20
    tagtag   206 天前
    说白了苹果就是不想让你做兼容,这样苹果才能保持高升级率,高换机率
    xfrgux
        21
    xfrgux   206 天前
    意思就是叫你们别兼容 iOS11 以下的系统了,iOS10 已经是 5 年前了,有苹果背书找理由还不开心吗。国外 App 一般只兼容 2-3 个版本,比如 twitter 现在要去 13.4 。
    在老旧系统上浪费时间不管对苹果、开发者、消费者都没什么好处,不应该为了那 5%的人牺牲大多数人的利益
    moooookey
        22
    moooookey   206 天前 via iPhone
    有些儿童教育类 APP,需要兼容低版本,很多人家还有没升级的老 iPad
    66beta
        23
    66beta   206 天前
    @xfrgux
    @tagtag
    苹果的好意,开发者都心领了...
    但是客户不升级,然后又来投诉,研发部门能怎么办,真是,淦

    用户是 6s+,可以升级到 12 的,人家就是守着 10.3.1 能怎么办,这种用户还特别爱投诉,淦
    MengiNo
        24
    MengiNo   206 天前
    我记得 iOS9 的 Safari 甚至都不能算 “现代浏览器” 了,这也要支持,真的有数据支撑么。
    66beta
        25
    66beta   206 天前
    @MengiNo 二级部门,没有发言权,叫你支持就要支持
    swordne
        26
    swordne   206 天前
    @66beta
    键盘给他,让他写,[doge]
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   4200 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 29ms · UTC 06:23 · PVG 14:23 · LAX 22:23 · JFK 01:23
    ♥ Do have faith in what you're doing.