V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Mateverse
V2EX  ›  Android

请诸位 Android 开发者选择 X5 内核,避免使用 UC webview sdk

  •  
  •   Mateverse · 114 天前 · 4491 次点击
    这是一个创建于 114 天前的主题,其中的信息可能已经有所发展或是发生改变。
    1. 需要注册,申请 APPID
    2. 不支持 skiavk ,部分原生系统默认使用 VK 的情况下,出现大面积福报系列 APP 白屏情况,需要手动修改debug.hwui.renderer=skiagl 。X5 内核没问题 。

    我的体验:类原生 Android12 ,支付宝小程序无一幸免,alipay 运动页面打不开,钉钉部分页面白屏,包括登录验证码验证页面。淘宝部分店铺打不开。有用 uc webview sdk 的同学请注意一下。

    31 条回复    2022-05-09 17:54:24 +08:00
    codefever
        1
    codefever  
       114 天前   ❤️ 2
    2022 年了,没想到还能出这种问题
    BigBai
        2
    BigBai  
       114 天前 via Android
    `debug.hwui.renderer=OpenGL`试一下呢
    Mateverse
        3
    Mateverse  
    OP
       114 天前
    @BigBai 也是可以的。
    imzcg2
        4
    imzcg2  
       114 天前 via Android
    为什么会出现这种情况呢,得益于自由既混乱,根本就做不到像 iPhone 那样一个 webkit 走天下,你好我好大家好
    Ga2en
        5
    Ga2en  
       114 天前   ❤️ 29
    请诸位 Android 开发者选择 google webview ,避免使用 X5
    zagfai
        6
    zagfai  
       114 天前   ❤️ 1
    是啊 google 不用 用啥 x5?
    murmur
        7
    murmur  
       114 天前
    @imzcg2 别提了,苹果两个大深坑我都是踩到 safari 核心上,安卓还可以替换 webview ,一样的旧也是好事,新特性未必有用,但是不升版本代表没有新问题
    Goooler
        8
    Goooler  
       114 天前   ❤️ 1
    干嘛不用原生的 WebView 呢,之前碰到过几次 x5 造成的内存泄漏,已经按照官网的指导使用了,从那之后就没好印象了
    mxT52CRuqR6o5
        9
    mxT52CRuqR6o5  
       114 天前 via Android
    我小米手机试用安卓 11beta 版时也是一堆福报系 app webview 页白屏
    hatsuyuki
        10
    hatsuyuki  
       114 天前
    @imzcg2 iOS 浏览器内核兼容性太差,部分功能实现不规范,而且还强制使用,毒瘤
    xiangyuecn
        11
    xiangyuecn  
       114 天前   ❤️ 1
    google webview ?呸 ~ 🐶🐶🐶

    不是说系统自带的哪里不好,其实本身够先进。但这玩意就和当年的 IE 一模一样(更新钉子户 升级异常困难),只能唾弃了。没有跨版本兼容需求 当然感知不到 系统自带 webview 是最好选择。

    ---------

    一直质疑 Android 沙雕 webview (包括 iOS 沙雕 webview ),一个简单的升级功能都不能提供(比如:开发者可以默认使用系统自带的古董内核,或者选择使用最新稳定内核(没必要指定版本),系统自动维护,在我眼里最多 100 行代码搞定🐶,不能再多了)
    Mateverse
        12
    Mateverse  
    OP
       114 天前
    @xiangyuecn 他们估计也都不是 Android 开发,我就没回。真正用过 webview 的,才知道为什么选择第三方。
    hingbong
        13
    hingbong  
       114 天前
    有咕咕 play 的话,倒是可以更新 webview 了现在
    Mateverse
        14
    Mateverse  
    OP
       114 天前
    @hingbong 更新过了,依然不行。内核是版本号 64 的 chrome 的 UC WEBVIEW SDK 。
    hingbong
        15
    hingbong  
       114 天前
    @Mateverse 我只是针对“自带 webview 不更新”🤣
    zpxshl
        16
    zpxshl  
       114 天前   ❤️ 1
    @zagfai 谷歌能解决碎片化吗,这么多版本。 何况还有国内厂商对 webview 内核的魔改,用原生 webview 问题量直接起飞
    PerFectTime
        17
    PerFectTime  
       114 天前   ❤️ 1
    呸,辣鸡 X5 ,请避免使用 X5 。

    辣鸡 X5 快点死
    yousabuk
        18
    yousabuk  
       114 天前 via iPhone   ❤️ 1
    X5 是个锤子🔨
    kssdxw
        19
    kssdxw  
       114 天前   ❤️ 1
    用 firefox 的 GeckoView ,我们目前用这个从 4.2 兼容到 12 ,比 x5 好用太多了
    12101111
        20
    12101111  
       114 天前
    我能理解 x5,uc 这种魔改 webview 的市场
    国内不像国外, 都有 google play, google play 能自己更新 webview, 国产手机有的系统不点进应用商店就不会自动更新。
    不过我还是希望在系统的 webview 的 chromium 版本比 x5 自己的版本高时调用系统的,我看 x5 的官网说 x5 才更新到 77, 简直是文物版本,现在 Google 都是对着 Chromium/Firefox/Safari 最新 3 个版本适配的,qt6 webengine 的 chromium 94 都说老
    janus77
        21
    janus77  
       114 天前
    额,说实话我对阿里做出来的第三方 sdk 一直持有抵触态度,感觉他家的东西都是魔改太过头,一开始就是从自己内部业务高度定制的,然后稍作接口抽象就开放出来给人用。。。。
    x5 的话,稳定性和兼容性还不错,也就是性能不及 google 的,然后加上近几年安卓的策略导致兼容性问题慢慢减少,所以复杂性比较低的项目也可以尝试切成 google 家,x5 就没那么大优势了
    zpxshl
        22
    zpxshl  
       114 天前
    @12101111 其实国内更大的问题是各家手机厂商魔改 webview
    fhbyljj
        23
    fhbyljj  
       114 天前 via Android
    @Mateverse 其实 V2EX......非编程的用户已经占大多数了
    Mateverse
        24
    Mateverse  
    OP
       114 天前   ❤️ 2
    @fhbyljj 确实。而且上面没几个人是来就事论事回答问题的。
    learningman
        25
    learningman  
       114 天前 via Android   ❤️ 1
    X5 傻逼,但是 X5 是稳定的傻逼,你能保证所有用户是一样的。
    webview 可能新也可能旧,本来没问题更新一下系统炸了,你觉得用户能理解吗
    tuimaochang
        26
    tuimaochang  
       112 天前
    UC 是真的沙雕,有个几个旧版能播放自定义 url 的 mp4 但是输入框不自动弹输入法。把输入法的 bug 解决以后 mp4 无法播放了
    tuimaochang
        27
    tuimaochang  
       112 天前
    点击输入框的时候输入法不能自动把输入框顶上去,草
    magicls
        28
    magicls  
       102 天前
    说实话,国内做 webview 的有几个是真正从技术层面想好好做的?还不是为了方便自家各种骚操作。

    亲亲这边建议直接用原生 webview
    WebKit
        29
    WebKit  
       101 天前
    楼上这么多说用原生 webview 的?你能保证兼容 Android 5.0 到 Android 12 ?目前最好的就是 X5 了,SDK 只有几百 K ,跟微信 QQ 公用一个 webview,没有也能动态下载。
    lns103
        30
    lns103  
       100 天前 via Android
    @WebKit 兼容没有魔改 Webview ,并且能够访问 Google play 的设备完全没问题,android 5.0 已经不提供 webview 更新了,只需要适配最后一个版本,6.0 以上都会通过 Google play 自动更新到最新的 Webview 。
    当然国内的混乱安卓生态就不说了。
    作为一个个人用户,我很讨厌第三方内核,因为速度慢( QQ 微信禁用 x5 可以显著提升首次打开网页的速度),并且每个应用都会下载几十到一百 m 的内核(并不能共用,QQ 微信也是各自下一个),我手机里的 x5 和 UC 内核占用加起来有 3GB ,我宁愿安装一个 x5 app 和 UC 让所有应用调用。
    WebKit
        31
    WebKit  
       100 天前
    @lns103 #30 “能够访问 Google play 的设备” 在国内可以忽略这部分用户了。
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1300 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 27ms · UTC 19:05 · PVG 03:05 · LAX 12:05 · JFK 15:05
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.